must i make the security protection provided following the most security breach that is recent?